Get in touch
Back
Downtime

US Environment B

Started 22 Jun at 02:41pm MDT, resolved 22 Jun at 03:43pm MDT.

US Environment
Resolved

US Environment B - Services restored

Posted 22 Jun at 03:43pm MDT.
Created

You may have been impacted by service disruptions in Filevine on Tuesday, June 21 2022. We know you depend on Filevine to run your business and we take that very seriously. We are so sorry for the disruption to your business and your ability to deliver results for your clients. We have restored service as of 4:00pm MST on Tuesday, June 21 2022.

So what happened? There was an unscheduled surge of legitimate activity beyond what had ever been observed in Filevine. Previously, we were well positioned to handle more than the maximum amount of activity that had been observed. During our remediation efforts to handle the increased load, an upgrade to our infrastructure failed and took our service down. We have installed immediate upgrades and are now capable of handling exponentially more activity than our current maximum activity. Again, we are sorry for this disruption to your business, but are confident that the work we’re undertaking will enable us to deliver an even better product and experience for you for years to come.

Posted 22 Jun at 02:41pm MDT.